Back to overview
Maintenance

Booking system maintenance

Jun 4, 2026 at 6:12am UTC  –  Jun 5, 2026 at 8:00pm UTC
Affected services
Booking Page

Resolved
Jun 5, 2026 at 8:00pm UTC

Maintenance ended

Created
Jun 4, 2026 at 6:12am UTC

The booking system is currently undergoing scheduled maintenance to accommodate upstream changes.